Purchase the Standard
Where to get copies of the standards that comprise “Green Button”
“Green Button” is composed of many different standards. Some are available for free on the Internet, while others require a nominal fee (or membership in those organizations instead of a fee).
W3C Standards
Internet Engineering Task Force (IETF) Standards
- RFC 3339 -- Date and Time on the Internet: Timestamps
- RFC 4122 -- A Universally Unique IDentifier (UUID) URN Namespace
- RFC 4287 -- The Atom Syndication Format
- RFC 5023 -- The Atom Publishing Protocol
- Green Button Alliance -hosted schema file (v4.1):
- Transport Layer Security (TLS) Protocol:
- OAuth 2.0:
North American Energy Standards Board (NAESB) Standards
- NAESB’s Energy Services Provider Interface (ESPI)
- NAESB REQ.21 ESPI ver 4.1
- minor updates
- NAESB REQ.21 ESPI ver 4.0
- deprecated of TLS 1.2
- added of bill-image retrieval
- NAESB REQ.21 ESPI ver 3.3
- replaced OAuth 1.0 with OAuth 2.0 for
Confidential Clients
- require TLS 1.2 as a minimum
- revised the Energy Usage Information (EUI) data structure and definitions
- added the Retail Customer (PII) data structure and definitions
- deprecated original Use Cases that do not meet OAuth 2.0 data security requirements
- added use case for Download My Data (DMD)
- simplified use case 2:
Customer Authorization process
- documented standard ESPI application program interface (API) formats
- replaced OAuth 1.0 with OAuth 2.0 for
- Green Button Alliance -hosted schema files (v4.1):
- NAESB REQ.21 ESPI ver 4.1

